VuFind
  1. VuFind
  2. VUFIND-1258

KohaILSDI returns wrong name in function patronLogin

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1
    • Fix Version/s: 4.1.2
    • Component/s: ILS Driver
    • Labels:
      None
    • Environment:
       Ubuntu 16.04.3 LTS

      Description

      When entering a comment in VuFind the name of the commentator is stored in user.lastname (referenced using comments.user_id).

      In VuFind 4.1 user.lastname is always set to "unknown". This is caused by assigning a wrong Koha field in the statement

            'lastname' => $this->getField($rsp->{'lastname'}).

      Should be
            
             'lastname' => $this->getField($rsp->{'surname'}

      instead.

        Activity


          People

          • Assignee:
            Unassigned
            Reporter:
            Roland Keck
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: