Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Hi, I am new here.

      I have installed vufind2.4 into the server but the server use proxy to connect internet. Is there any configuration in vufind to get the connection?

      Thank you.

        Activity

        Hide
        Demian Katz added a comment -
        You should be able to configure your proxy server in this section of config.ini:

        https://github.com/vufind-org/vufind/blob/master/config/vufind/config.ini#L1109

        I'm closing this ticket for now; this system is generally intended for bug reports and feature requests. For more general-purpose support, I would encourage you to join the vufind-general and/or vufind-tech mailing lists, as described here under Community Support:

        https://vufind.org/vufind/support.html

        Please let me know if you need further assistance -- I'm always happy to help!
        Show
        Demian Katz added a comment - You should be able to configure your proxy server in this section of config.ini: https://github.com/vufind-org/vufind/blob/master/config/vufind/config.ini#L1109 I'm closing this ticket for now; this system is generally intended for bug reports and feature requests. For more general-purpose support, I would encourage you to join the vufind-general and/or vufind-tech mailing lists, as described here under Community Support: https://vufind.org/vufind/support.html Please let me know if you need further assistance -- I'm always happy to help!
        Hide
        Demian Katz added a comment -
        Which book cover option(s) are you using? Perhaps one of them needs to be adjusted to use the proxy correctly.

        - Demian
        Show
        Demian Katz added a comment - Which book cover option(s) are you using? Perhaps one of them needs to be adjusted to use the proxy correctly. - Demian
        Hide
        Demian Katz added a comment -
        A quick review of the code suggests that (even back in version 2.4) both the Google and Amazon cover handlers were using VuFind's central HTTP service, which in turn should be respecting the proxy settings in config.ini.

        There have been some adjustments to the proxy logic in newer releases of 2.4. Do you have the ability to test with a newer release to see if that offers different results?

        Are you using a non-default HTTP adapter at https://github.com/vufind-org/vufind/blob/release-2.4/config/vufind/config.ini#L800 ? That could make a difference, too.
        Show
        Demian Katz added a comment - A quick review of the code suggests that (even back in version 2.4) both the Google and Amazon cover handlers were using VuFind's central HTTP service, which in turn should be respecting the proxy settings in config.ini. There have been some adjustments to the proxy logic in newer releases of 2.4. Do you have the ability to test with a newer release to see if that offers different results? Are you using a non-default HTTP adapter at https://github.com/vufind-org/vufind/blob/release-2.4/config/vufind/config.ini#L800 ? That could make a difference, too.

          People

          • Assignee:
            Unassigned
            Reporter:
            Farid Kamil
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: