VuFind
  1. VuFind
  2. VUFIND-217

Tags added outside of favorites cannot be removed.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0RC1, 1.0RC2
    • Fix Version/s: 1.4
    • Component/s: Record
    • Labels:
      None

      Description

      If you add a tag on the record view page using the "add" button in the tag section (not through the "add to favorites" interface), the tag is associated with the record anonymously (list_id and user_id are NULL in the resource_tags table). As a result, there is no obvious way to remove or change this tag.

      A few possible solutions:

      1.) Allow any user to delete anonymous tags.
      2.) Allow anonymous tags to be removed through some kind of admin-only interface.
      3.) Associate tags with a user_id rather than making them completely anonymous (may require some code changes, and doesn't resolve legacy codes added before the change was made -- more things to think about).

      Feel free to make suggestions about the best approach to this problem.

        Activity

        Demian Katz added a comment -
        In reviewing the code, I just noticed that tags are entered anonymously due to a bug -- I don't think this behavior was ever meant to be a feature! I'm not going to fix the bug yet because I want to review the possible consequences of changing the behavior... but this discovery may help influence our decision on how to solve the problem once and for all!
        Demian Katz added a comment -
        I have fixed the bug that prevented tags from being linked to users in r3434. This has no apparent effect on existing functionality, but it opens the possibility of allowing users to delete their own tags fairly easily. We should work on implementing this feature in the near future. We should also include a tool in the next upgrade script to associate old anonymous tags caused by the bug with a particular user account so that they can be more easily managed.
        Demian Katz added a comment -
        The EvolvePlus VuFind Manager offers an administrative interface for managing tags outside of VuFind itself:

        http://www.evolveplus.com.au/download-vufind-manager

        This functionality should eventually be integrated into VuFind's Admin module.
        Demian Katz added a comment -
        On the subject of tag administration, see also VUFIND-743.
        Demian Katz added a comment -
        Since the "anonymous tag" problems described by this ticket were resolved some time ago, I am going to close it as resolved. The only outstanding issue is the lack of a UI element for editing/deleting your own record tags, which I am addressing with a new ticket: VUFIND-905.

          People

          • Assignee:
            Unassigned
            Reporter:
            Demian Katz
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: